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2 Introduction 

Proxy Server CCProxy is easy-to-use and powerful Internet connection sharing software. 

Supporting broadband, DSL, dial-up, optical fiber, satellite, ISDN and DDN connections, it 

helps you build your own proxy server and share Internet access within the LAN efficiently 

and easily. CC Proxy Server can act as HTTP, mail, FTP, SOCKS, news and telnet proxy 

server. And it features powerful account management functions, including Internet access 

control, bandwidth control, Internet web filtering, content filtering and time control. It also 

provides web caching, online access monitoring, access logging and bandwidth usage 

statistics functions. CC Proxy is compatible with Win98, WinME, WinNT, Win2000, WinXP, 

Win2003, Vista, Win7 and Win2008. 
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3 Main Features 

1. Modem, Cable Modem, ISDN, ADSL, Satellite, DDN and so on are supported.  

2. HTTP, FTP, Gopher, SOCKS4/5, Telnet, Secure (HTTPS), News (NNTP), RTSP and 

MMS proxy are supported.  

3. Port Mapping is supported.  

4. Web cache can enhance browsing speed. The size and refresh time of the cache can 

be easily changed.  

5. Bandwidth control flexibly manages the traffic usage of clients.  

6. Time schedule can easily control the clients' on-line time  

7. Web filter can ban the specified web sites or content. It can also name specific web 

sites for browsing.  

8. URL filtering prevents users from downloading files with designated extensions via IE.  

9. There are seven types of account authentication: IP address, IP range, MAC address, 

User Name/Password, IP + User Name/Password, MAC + User Name/Password and 

IP + MAC.  

10. Parent proxy function enables CCProxy to access the Internet via another proxy.  

11. Dial-On-Demand, remote dial up and auto disconnect are supported.  

12. Access Logging can keep a full record of the Internet access log.  

13. It enables IE and Netscape to access the Internet through HTTP/Secure/FTP 

(Web)/Gopher.  

14. SOCKS5 proxy support allows use of ICQ, MSN Messenger, Yahoo Messenger, 

CuteFTP, CuteFTP Pro and WS-FTP.  

15. Mail proxy supports Outlook, Eudora etc.  

16. Supports NetTerm accessing the Internet via Telnet proxy.  

17. Supports Outlook connecting to the News server via News proxy.  

18. Support SOCKS5 and web authentication.  

19. Support for Real Player RTSP proxy and Media Player MMS proxy.  

20. Built-in DNS can resolve domain names.  

21. Win98/WinMe/WinNT/Win2000/WinXP/Win2003/Vista/Win7/Win2008 compatible.  

22. Bandwidth usage statistics. 
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4 Installation 

4.1 Step 1 - LAN networks configuration 

Normally, the clients and server are connected with A Hub, Wireless Hub, Switch or 

Router. The network protocol between the server and clients is TCP/IP. Therefore both the 

server and the clients have an IP address. The server IP address is static and fixed. The 

clients IP address can be fixed or dynamic which is obtained through DHCP. CCProxy 

only requires that the clients can ping through the server IP address. We know that the 

server may have multiple IP addresses, but must have one that is used to connect with 

other LAN clients. The IP address that is used to connect with the other LAN client is 

called the proxy server address. We generally assumed this to be 192.168.0.1. 

If the clients and server have not yet been setup to have a connection, we recommend 

allocate IP addresses like this at below: 

 

  IP ADDRESS MASK GATEWAY DNS 

Server 192.168.0.1 255.255.255.0 empty empty 

Client1 192.168.0.2 255.255.255.0 192.168.0.1 192.168.0.1 

Client2 192.168.0.3 255.255.255.0 192.168.0.1 192.168.0.1 

... ... ... ... ... 

Client99 192.168.0.100 255.255.255.0 192.168.0.1 192.168.0.1 

 

How to detect whether ping requests are transferring through between the clients and 

server? At the client, in the "start" menu -> "run" -> "cmd", assuming that the server IP is 

192.168.0.1, in the command line, to type "ping 192.168.0.1" then press return. If the 

result is similar to that at below, it means the client is connected to the server successfully.  

 

PINGING 192.168.0.1 WITH 32 BYTES OF DATA: 

REPLY FROM 192.168.0.1: BYTES=32 TIME=2MS TTL=150 

REPLY FROM 192.168.0.1: BYTES=32 TIME=2MS TTL=150 

REPLY FROM 192.168.0.1: BYTES=32 TIME=7MS TTL=150 

REPLY FROM 192.168.0.1: BYTES=32 TIME=7MS TTL=150 

PING STATISTICS FOR 192.168.0.1: 

PACKETS: SENT = 4, RECEIVED = 4, LOST = 0 (0% LOSS), 

APPROXIMATE ROUND TRIP TIMES IN MILLI-SECONDS: 

MINIMUM = 2MS, MAXIMUM = 7MS, AVERAGE = 4MS  
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If the result is like that at below, it means the client cannot connect to the server.  

 

PINGING 192.168.0.1 WITH 32 BYTES OF DATA: 

REQUEST TIMED OUT. 

REQUEST TIMED OUT. 

REQUEST TIMED OUT. 

REQUEST TIMED OUT. 

PING STATISTICS FOR 192.168.0.1: 

PACKETS: SENT = 4, RECEIVED = 0, LOST = 4 (100% LOSS), 

  

If the client cannot connect to the server, you need to check the IP address settings and 

the connections to the Hub, Switch or Router on the clients and server. 

4.2 Step 2 - Internet connection 

We know that there are many ways of connecting to the Internet, which are for example, 

ADSL, optical fiber, satellite, broadband etc. CCProxy is not concerned about the manner 

in which the Internet connection is established, as long as the server is successful 

connected to the Internet.  

The simplest way to check the server can access the Internet is to input a web site 

address into the browser and see if the machine is able to access the web pages. 

Users frequently mentioned single and dual NIC. In fact, the CCProxy is not concerned 

with hardware equipment. Both single and multi-NIC cards are supported and there are no 

special settings. 

Special mention is that if the clients have been able to share the Internet, such as through 

the router, and hope to use the CCProxy to manage and control the clients' Internet 

access. You might need to do some changes on your hardware. 

 

For example: 

CLIENTS  ---  ROUTER  --- SERVER  

    |      

    Internet      

  

or  

 

CLIENTS ---  HUB (SWITCH)  ---  SERVER 

    |     

    Router  ---  Internet 

  

In this case, the clients can access the Internet directly with the Routers bypass proxy 

server. That's to say, CCProxy cannot control the clients. We need to isolate the client 
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from Internet and force clients to access the Internet via the proxy server. 

 

We have two methods to realize this. 

Method 1: 

Add one NIC card on the server and change the LAN networks as: 

 

CLIENTS  ---  ROUTER  --- SERVER  --- INTERNET  

Or 

 

CLIENTS  --- HUB (Switch)  --- SERVER  --- ROUTER  --- INTERNET  

 

Method 2: 

Configure the NAT in the router and block all LAN IP address accessing NAT except the 

server IP address. Only some advanced routers have this function. Please do this with the 

router's administrator.  

4.3 Step 3 - Install CCProxy software at server 

Please download the latest version of CCProxy installation package from our site first. 

Running the installation package at server will install CCProxy to C:\CCProxy by default. 

Launch CCProxy and open the "options", the proxy server address is displayed in the 

"Local LAN IP address". Please check whether it's the proxy server address or not. If not, 

please uncheck "Auto Detect". Select the correct proxy server IP address from the 

drop-down list and check the checkbox on the right side. 

Now, CCProxy has been installed on the server with default settings, CCProxy will permit 

all clients access Internet. If you want to manage the clients, please read "Account 

Management".  

If you get problem in launch CCProxy, please refer to "FAQs". 

4.4 Step 4 - Configure IE browser proxy settings at 

clients 

At the clients machine, please open IE menu "Tools", go to "Internet Options" -> 

"Connections" -> "LAN settings", select "proxy server", input the proxy server IP address 

in the "Address", 808 in the "Port". Select "local address bypass proxy". IE proxy setup is 

finished and we can access websites via the proxy now. 

For other network applications' proxy settings, please refer to "Client Proxy configuration". 
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5 Client Proxy Configuration 

In this section, we will talk about the proxy settings of client software. CCProxy is proxy 

server software. If the client wants to access the Internet via CCProxy, some proxy 

settings need to be set up in the client software. Below we provide guides for proxy 

settings for popular client software. Each guide is based on the assumption that the proxy 

address is 192.168.0.1. If you know other client software's proxy settings, please email us. 

We will publish them on our site for the benefit of other users. 

5.1 IE (Internet Explorer) 

Launch IE -> menu "Tools" -> "Internet Options" -> "Connections" -> "LAN settings" -> 

choose "use a proxy server" -> "advanced" -> "servers" -> add" server address" to "HTTP", 

"Secure", "FTP", "Gopher", Port is 808; add "server address" to "Socks", Port is 1080. 

 

 

Figure 5-1-1 

 



CCProxy – Proxy Server Software for Windows                   http://www.youngzsoft.net/ccproxy/ 

 9

 

Figure 5-1-2 

 

 
Figure 5-1-3 
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5.2 Firefox 

Click the menu "Tools" -> "Options", click the button “Advanced” and select the tab 

“Network”. 

 

Figure 5-2-1 

 

Click the button “Settings”, and fill the settings as below. 
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Figure 5-2-2 

5.3 Outlook Express  

1. Suppose email address is support@youngzsoft.net. 

Mailbox account name: support 

Password: *********** 

SMTP address: smtp.youngzsoft.net 

POP3 address: pop3.youngzsoft.net  

Proxy server address: 192.168.0.1 

 

2. Open Outlook Express, click the "Tools" menu, and select "Accounts". 

3. Click “Add”, and then click “Mail …” 

4. Enter your name in the “Display name” field, and click “Next”. 

5. Enter your full email address in the “Email address” field, and click “Next”. For 

example, support@youngzsoft.net 

6. Enter the proxy server address in the “Incoming mail (POP3, IMAP or HTTP) server” 

field. For example, 192.168.0.1. Enter the proxy server address in the “Outgoing mail 

(SMTP) server” field. For example, 192.168.0.1. 

7. Click “Next”. 

8. Enter “your email account name” + “#” + “your email POP3 server address” in the 
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“Account name” field. For example, support#pop3.youngzsoft.net. Enter your email 

password in the “Password” field, and click “Next”. 

9. Click “Finish”. 

10. Highlight 192.168.0.1 under “Account”, and click “Properties”. 

11. Click the “Servers” tab, and check the box next to “My server requires authentication”. 

Click “Settings”. 

12. Select “Log on using”. Enter “your email logon account name” + “#” + “your email 

SMTP server address” in the “Account name” field. For example, 

support#smtp.youngzsoft.net. Enter your email logon password in the “Password” 

field. 

13. Click “OK”. 

14. Click “OK”. 

5.4 Outlook Express for Gmail 

Gmail is different from other email service. The POP3 and SMTP are using SSL 

connection. We have to use a different method to configure Gmail proxy settings in 

Outlook Express than other normal email account.  

1. Open the "Options" dialog box and click the "E" button to open the "Port Map" dialog 

box (Figure 5-4-1).  

 

Figure 5-4-1 

2. Add a port map rule for SMTP service of Gmail: fill "smtp.gmail.com" in the "Dest 

Host", "465" in the "Dest Port", "465" in the "Local Port" and select "TCP" in the "Port 
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Type". Click the "Add" button (Figure 5-4-2).  

 

Figure 5-4-2 

3. Add a port map rule for POP3 service of Gmail: fill "pop.gmail.com" in the "Dest Host", 

"995" in the "Dest Port", "995" in the "Local Port" and select "TCP" in the "Port Type". 

Click the "Add" button (Figure 5-5-3).  

 

Figure 5-4-3 
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4. Open outlook express account properties page and click the "Servers" tab. Suppose 

proxy server address is 192.168.0.1. Fill "192.168.0.1" in the "Incoming mail" and 

"Outgoing mail". Here we take "youngzsoft@gmail.com" for demo and you need to 

use your gmail account in your case.  

 

Figure 5-4-4 

5. Check the "My server requires authentication" and click the "Settings" button in 

"Servers" tab page. The "Outgoing Mail Server" dialog box will popup (Figure 5-4-5). 

Select the "Use same settings as my incoming mail server" and click the "OK" button.  

 

Figure 5-4-5 

6. Click the "Advanced" tab and check the "SMTP SSL" and "POP3 SSL". Fill "465" in 
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the "SMTP" and "995" in the "POP3". Select the “This server requires a secure 

connection (SSL)” (Figure 5-4-6).  

 

Figure 5-4-6 

7. Click the "OK" button.  

8. When you receive the Gmail account at the first time, the Outlook Express will popup 

the confirm dialog box. Please confirm it. 

 

Figure 5-4-7 

5.5 Office Outlook 

We take Office Outlook 2003 for example.  

Email address: support@youngzsoft.net. 
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Mailbox account: support 

SMTP address: smtp.youngzsoft.com 

POP3 address: pop3.youngzsoft.com  

Proxy server address: 192.168.0.1 

 

1. Download and install the latest updates for Outlook from Microsoft website: 

http://office.microsoft.com/en-us/officeupdate/default.aspx 

2. Open Outlook. 

3. Click the “Tools” menu, and select “E-mail Accounts …” 

4. Click “Add a new e-mail account”, and click “Next”. 

5. Choose “POP3” as your server type by clicking the radio button, and click “Next”. 

6. Fill in all necessary fields to include the following information: 

User Information 

Your Name: Enter your name. 

E-mail Address: Enter your full email address, i.e. support@youngzsoft.net. 

Server Information 

Incoming mail server (POP3): Enter the proxy server address, i.e. 192.168.0.1. 

Outgoing mail server (SMTP): Enter the proxy server address, i.e. 192.168.0.1. 

Logon Information 

User Name: Enter your email logon user name + # + your email POP3 server 

address, i.e. support#pop3.Youngzsoft.net. 

Password: Enter your email password 

7. Click “More Settings …” and then click the “Outgoing Server” tab. 

8. Check the box next to “My outgoing server (SMTP) requires authentication” and 

select “Log on using”. 

User Name: Enter your email logon user name + # + your email SMTP server 

address, i.e. support#smtp.Youngzsoft.net 

Password: Enter your email password. 

9. Click “OK”. 

10. Click “Test Account Settings…” After receiving “Congratulations! All tests 

completed successfully”, click “Close”. 

11. Click “Next”, and then click “Finish”. 

  

5.6 Outlook Express for News (NNTP)  

Choose the configured News server in Outlook Express, right click menu and select the 

“Properties” -> “Server”. 

Suppose the original server name is "msnews.microsoft.com". You need to change the 

server name to the proxy server's address. Select the "This server requests to log on", fill 

"#msnews.microsoft.com" in the “Account” and leave the "Password" blank. Check the 

"Remember Password".  

If the News server you log onto requires account and password, the account name should 
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be set to "original account name” + “#” + “original news server address". 

5.7 CuteFTP 

Open menu "Edit" -> "Settings" -> "Connection" -> "Firewall", fill proxy server address in 

the "Host" and “2121” in the “Port”. Choose "USER user@site" in the "Type" and check 

the "Enable firewall access". 

5.8 CuteFtp Pro 

Open menu "Edit" -> "Global Settings" -> "Connection" -> "SOCKS4 & 5". 

Choose "Use the highlighted Socks server when connecting"; click button "Add", delete 

"<New>" in Host, fill in proxy server address. Port is 1080. 

Don't choose "Use Authentication". Choose "Socks5". 

5.9 ICQ 

Launch ICQ -> Menu "Main" -> Preferences -> "Connection": 

Select "Use Firewall" in "Server" tab. Select "Socks5" in "Proxy" tab. 

"Firewall": Select "Socks5". Fill proxy address in "Host", "Port" is 1080. Select "use proxy 

to resolve hostnames". 

5.10 MSN Messenger 

Menu "Tool" -> "Options" -> In "Connection" tab, check "I use proxy server", choose 

SOCKS 5 in type, fill local proxy servers IP address in "Server". Port is 1080. 

5.11 Voice/video chat software 

You need to install SocksCap32 at client, add voice chat software into SocksCap32 and 

launch it from SocksCap32. 

For specific guide, please refer to http://www.youngzsoft.net/sockscap/. Currently 

CCProxy cannot support MSN and Yahoo voice/video chat. If you want to use voice/video 

chat, we suggest you use skype. In skype, the Internet Explorer proxy settings are used. 
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5.12 NetMeeting 

As NetMeeting doesn't support proxy setting, SocksCap is needed. For more details, 

please refer to http://www.youngzsoft.net/sockscap/. 

5.13 Real Player 

Take RealPlayer 10.5 for example:  

Proxy server address is 192.168.0.1. 

HTTP/RTSP proxy port is 808.  

 

Menu "View" -> "Preferences" -> "Proxy" 

 

Figure 5-13-1 

 

Click the button “Change Settings” in the “Streaming Settings”. Set the settings as below 

(Figure 5-13-2): 
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Figure 5-13-2 

 

5.14 Windows Media Player 

Please upgrade the Media Player to version 11 first. 

Proxy Server address: 192.168.0.1. 

SOCKS/MMS proxy port: 1080 

HTTP proxy port: 808 

 

Click the menu "Tools" -> "Options" -> "Network" 
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Figure 5-14-1 

 

Select the “HTTP” in the “Streaming proxy settings”, click the button “Configure…” and set 

the settings as below (Figure 5-14-2): 
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Figure 5-14-2 

 

Click the button “OK” and select the “RTSP” in the “Streaming proxy settings”, click the 

button “Configure…” and set the settings as below (Figure 5-14-3): 
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Figure 5-14-3 

  

5.15 NetTerm for BBS telnet 

Open menu "File"-> "Phone Directory". 

Choose the BBS in the list you want to log on. E.g. bbs.execpc.com. 

Follow info will be shown: Host Name is bbs.execpc.com; No entry in Host/IP and telnet 

port is 23. Fill in proxy server address in Host/IP. Click button "Connect". Follow info will be 

showed on blue screen: CCProxy Telnet>CCProxy... 

Input "open bbs.execpc.com", click "Enter" key. Now you can log on bbs.execpc.com. 

5.16 Java application for Game/Chat room 

First of all, you need to install Sun JRE (Java Runtime Environment). You can download it 

free at http://www.java.com. 

After installation: 

1. Go to Control Panel  

2. Double click the "Java Plug-in" icon  

3. Click the "Proxies" Tab  
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4. Make sure that the "Use Browser Settings" checkbox is checked. If it is not, then check 

it and hit the "Apply" button to save your changes. Doing this will cause the JRE to use the 

Web browser's proxy settings for all Internet connections.  

5. Close all browser windows. Restart the browser and try to load the applet.  

5.17 Norton AntiVirus for live update 

First, set HTTP proxy in IE. Open Live Update in Norton AntiVirus.  

Popup "Live Update" dialog box and click button "Configure". 

Popup dialog box "Live Update Configuration".  

In "ISP" tab, check "the Internet Options in Control Panel".  

In "Proxy" tab, check "I want to use my Internet Explorer Proxy Settings". 

5.18 AVG update 

Suppose proxy address is 192.168.0.1.  

AVG -> Update Manager -> Settings -> Proxy -> User proxy server, Server: 192.168.0.1, 

Port 808.  

5.19 Windows XP update 

Suppose proxy address is 192.168.0.1 and http port is 808.  

1. Click Start, click Run, type cmd, and then click OK.  

2. At the command prompt, type proxycfg -p 192.168.0.1:808, and then press ENTER. (Or 

type proxycfg -u, and then press ENTER)  

5.20 Other software  

If the software has the proxy option (generally in network settings or system settings) for 
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proxy configuration, you can configure the proxy according to the relative protocols and 

ports. Generally you can use SOCKS proxy settings (port is 1080) or HTTP proxy settings 

(port is 808). Also you can search proxy settings in google. For example, you can search 

"skype proxy settings" to find out how to set up proxy for skype. 

Otherwise, you will need to install SocksCap32, software from NEC on the client and add 

this software to SocksCap32. 

For specific guide, please refer to http://www.youngzsoft.net/sockscap/ 
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6 Account Management 

In this section we will talk about the account management of CCProxy. CCProxy features 

powerful Internet access control function. It helps the administrator to manage clients 

easily and efficiently. You can click the "Account" button on the toolbar of CCProxy to 

manage your account. The account management includes "Account List", "Web Filter" 

and "Time Schedule". We will introduce all of them in detail below.  

6.1 Account Manager 

Permitted Category: There are two options - "Permit All" and "Permit Only". "Permit All" 

means all proxy clients can access the Internet via CC Proxy. "Permit Only" means only 

the clients which have been given permission can access the Internet via CC Proxy. 

Auth Type: CCProxy account authentication supports IP Address, MAC Address and 

User/Password. Each account can be authenticated with these auth types. The 

"User/Password " authentication is only valid to web proxy and socks5 proxy service. 

Web Filter: The administrator can define the filter rule here. CCProxy supports "Web Site 

Filter"(Permit or forbidden), "Forbidden URL"(Web URL filter) and "Forbidden 

Content"(Web Content Filter). 

Time Schedule is used to control the clients' on-line time. 

New, Edit, Delete and Select All: These are used to create, edit or delete the account 

list. 

Auto Scan: This is used to scan the computers on the LAN and get the computers' 

information automatically. For example, computer name, IP address and MAC address. 

Export and Import: Export is used to save the account list information to a specific folder. 

Import is used to load account information from a specific file. These two features function 

just like the backup and restore operations of account list. 

NT User Auth: If you check this box, CCProxy will import the Active Directory accounts 

automatically. You can input the AD server name in the edit box. "." means local server.  

Flow Stats displays the bandwidth usage of each account. 

6.2 Create New Account 

"Account -> Permit Category -> Permit Only -> New". 

Enable is used to enable or disable the account. 

User/Group Name is used to define each account. It's also used as the username for 

User/password authentication. 

Password is used to define the account's password. 

IP Address/IP Range: you can input a single IP or IP range. For example: 192.168.0.1 or 
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192.168.0.1-192.168.0.10. 

MAC Address is used to define the client's MAC address. Click the "?" to get the MAC 

address by the IP address or computer name. 

As Group means this account is defined as a group account.  

Belongs to Group: you can add this account to any defined group. 

Maximum Connections refers to the maximum simultaneous connections. The value -1 

means no limitation. 

Download Bandwidth refers to the maximum download bandwidth of each connection. 

The value -1 means no limitation. 

Upload Bandwidth refers to the maximum upload bandwidth of each connection. The 

value –1 means no limitation. 

Services is used to choose the permitted services of this account. 

Web Filter: you can choose a defined web filter here. 

Time Schedule: you can choose a defined time schedule here. 

Auto disable at: the account will be disabled at this defined time automatically. 

6.3 Web Filter 

Web filter can effectively restrict clients access to particular web sites.  

"Account -> Web Filter" 

Web Filter includes Site Filter, URL Filter and Content Filter. 

Web Filter Name is used to define different web filter rules. 

Site Filter: Input the sites you want to filter in the edit box. Site filter supports wildcard 

character (*,?). Multiple sites should be divided by semicolon. For example:  

*.yahoo.com;???.hotmail.com;www.*.org.  

Also you can define port filter. For example:  

*:433, *.yahoo.com:80;*.hotmail.com:*;  

You can also input a web filter file name here. The web filter file format is one web filter for 

one line. For example: 

*.yahoo.com; 

*.hotmail.com; 

*.bbc.com:*; 

*.msn.com:433; 

Advanced DNS Filter: You can enter opendns dns address here and filter the website by 

opendns. 

Permitted Sites: clients can only access sites which are included in the site filters. 

Forbidden Sites: clients can not access sites which are included in the site filters. 

Forbidden URL: You can define the URL filter here. You can input whole or partial URLs. 

For example: 

http://www.google.com/;*.zip;*.exe;*/mail/;  

Forbidden URL is different from Site Filter. Site Filter only applies to the web host name 

and port, whereas Forbidden URL applies to the whole URL address. 

Content Prohibited can filter web pages with specific characters. If the web page 
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includes such characters, it will be banned. Input the characters you want to name in the 

edit box. Multiple characters should be divided by semicolon. For example: chat;travel.  

Note: This step is only to define a web filter rule. If you want to apply it to a specific 

account, you should edit the account's property and select the web filter rule for this 

account. 

6.4 Time Schedule 

Time schedule is used to control the clients' on-line time. 

"Account -> Time Schedule" 

Time Schedule Name is used to define different time schedule rules.  

Sunday to Saturday: This is used to set different on-line time schedules for business 

days. You can edit time schedule directly in the edit box or click the button besides edit 

box. In the popup "Time Table" dialog box, there are 24 time range choices. Note:"01:00" 

means Internet access is allowed from 00:00 to 01:00. "Apply to," means the time control 

of the day is only effective for checked choices.  

Note: This step is only to define a time schedule rule. If you want to apply it to the specific 

account, you should edit the account's property and select the time schedule rule for this 

account. 
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7 Main interface 

7.1 Toolbar Zone 

Start: To start CCProxy. 

Stop: To stop CCProxy. 

Options: To open the options dialog box. 

Account: To open the account dialog box. 

Register: To enter registration code. 

Monitor: To open the online logging monitor (more). 

Hide: To hide the interface. 

Help: Get help document. 

7.2 Online Information Zone  

Yellow curve: the current amount of bandwidth. 

Green curve: the current number of connections. 

 

Tips: If you double click this zone, it will open the monitor dialog box. 

7.3 Product Logo Zone 

Display the product logo. 

Tips: If you double click this zone, it will open the log information dialog box. 

7.4 System Information Zone 

U: Double click this option to check for upgrade information. If there is a new version, it will 

open the upgrade dialog box. 

0/0: To display the number of online connections and accounts. The left number is the 

amount of online connections. The right number is the number of online accounts. Tips: 

Double click this zone and you will open the Windows system management. 

Time: Display the server time.  

Tips: Double click this zone and you can go to the installation folder of CCProxy. 
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8 Options  

Open the options dialog box by clicking "options". 

Mail: To start mail proxy service. 

DNS: To start DNS proxy service. 

Web Cached: If checked, the HTTP proxy will load and store web pages to the proxy 

cache. 

Remote Dial-up: To enable remote dial-up from clients. 

Auto Startup: If checked, CCProxy interface will start automatically when Windows starts 

up. 

Port Map: To start port map service. You can click the "E" button to add or edit the port 

map rules. 

HTTP/RTSP: To start HTTP and RTSP proxy service and set proxy port. 

Secure: To start secure (HTTPS, SSL) proxy service and set proxy port. 

FTP (Web): To start web ftp proxy service and set proxy port. 

Gopher: To start gopher proxy service and set proxy port. 

SOCKS/MMS: To start SOCKS and MMS proxy service and set proxy port. 

FTP: To start FTP proxy service and set proxy port. 

Telnet: To start Telnet proxy service and set proxy port. 

News: To start News and NNTP proxy service and set proxy port. 

Notes: FTP (Web) proxy service is different from FTP proxy service. FTP (Web) is used in 

IE browser. IE access FTP site via FTP (Web) proxy service. And FTP proxy service is 

used on FTP client software such as CuteFTP, WS-FTP and etc.  

Local IP Address: To display and set local IP address. If you check "Auto Detect", 

CCProxy will auto detect which IP is the local IP address and display it in the comb box list. 

If you find that the result is incorrect, you need to uncheck "Auto Detect" and choose the 

correct local IP address from the list. You can select multiple IP addresses as the local IP 

address. When you choose one local IP address, you need to check the checkbox beside 

it. 

NT Service: If this is checked, CCProxy will be run as a Windows service. 

Advanced: To open the advanced options dialog box. 
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9 Advanced Options  

You can open an advanced options dialog box by selecting "Options -> Advanced". There 

are 7 tabs in this dialog box. 

Dial-up: To configure the dial-up service. 

Cache: To configure the web-cached function, i.e. cache size, cache update time. 

Cascading: To configure the cascading proxy, also called parent proxy, service. 

Log: To configure the proxy logging service, i.e. log size and log type etc. 

Mail: To configure the mail proxy service. You can change the mail proxy port here. 

Network: To configure the proxy network settings such as server IP address binding, 

socket idle timeout, etc. 

Others: To configure other proxy settings such as interface language and remote admin 

etc. 

9.1 Dial-up Page 

Dial-up Entries: To select dial-up entries 

Dial-up User Name: To set the dial-up user name. 

Dial-up Password: To set the dial-up password. 

Idle Disconnect Minutes: To set the disconnect minutes. 

Enable Auto Dial-up: To select which service can be dial-up automatically. 

9.2 Cache Page  

CCProxy's web caching is based on the IE cache storage technology. CCProxy will load 

and store the web pages into the IE cache files on the server.  

Cache Update Time: To set the update interval of the cache. 

Always Load from Cache: If this is checked, the HTTP proxy will always load web pages 

from the IE cache ignoring the cache update time. 

Check the "IE" button if you wish to change the web cache path and size. 

9.3 Cascading Page 

CCProxy supports cascading proxy, also called parent proxy.  

Local Protocol: To choose which local protocol will use cascading proxy. For example, if 

you select "All", all connections from clients will be redirected to the cascading proxy. If 

you select "WWW", all WWW connections from clients will be redirected to the cascading 

proxy. 
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Proxy Address: To set the cascading proxy server address. Both IP address and domain 

name are acceptable. 

Proxy Protocol: To set proxy service protocol that the cascading proxy server provides. If 

the cascading proxy provides HTTP proxy service, the connections from the client will be 

translated to the http proxy protocol and redirected to the cascading proxy automatically. 

Need Authorization: If the cascading proxy requires authentication, you need to set the 

authentication information in this zone. 

9.4 Log Page 

Save Logs to File: To set the log file path. 

Request URL: Save the URL access information into logs. 

Picture Info: Save the pictures access information into logs. 

Web Title Info: Save the HTML title information into logs. 

Maximum Lines: To set the maximum lines of the log files. 

New Log Daily: Create new log file daily. 

Flow Stats Time Interval: To set how often minutes the flow statistics will be saved to the 

log files. in.  

Enable Flow Stats: Save flow statistics into log files. 

Flow Stats: To open the flow statistics log file. 

Open Logs: To open the log file. 

Export Excel: To export the logs as Excel format. 

9.5 Mail Page 

SMTP Port: To set the SMTP proxy service port. 

POP3 Port: To set the POP3 proxy service port. 

Anti Spam Check with RBL: CCProxy will add a [SPAM] signature in to the spam email 

subject. CCProxy will use the RBL to check the spam email. Notes: Only non-SSL POP3 

connections can be checked. 

9.6 Networks Page 

Enable SOCKS4: To enable the socks4 and socks4a proxy service. 

Disable External Users: To disable the users' access out of the LAN. 

Server Bind IP Address: If the server is multiple-hosted, you can use a single IP address. 

"0.0.0.0" will select a server IP address automatically. 

Web Sites for On-line Checking: To set the web sites that are used to check the Internet 

connection status. 

Socket Idle Disconnect Minutes: To set the socket idle time out value. 
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Enable Multiple IPs Outgoing: If you have multiple IP addresses for outgoing, and you 

want to the clients use the different IP address to access the destination. You can check 

this option. If the client uses one of the server’s outgoing IP addresses as the proxy 

address, the client will access the destination with that IP address. 

Add Client IP in HTTP Header: CCProxy will add “X-Forwarded-For” in HTTP header and 

the “X-Forwarded-For” will include the client IP address. 

9.7 Others Page 

Language: To select the interface language. 

Enable Remote Admin: To enable the remote admin service. 

Admin Port: To set the remote admin service port. 

Admin Password: To set the admin password. 

Password Protection: If you check this option, when you open the account management 

dialog box, it you will need to enter a password to unlock it. When you close the dialog box, 

it will be locked again.  

Need Password When Startup: The startup will require a password. 

Notes: If you enable remote admin, you can manage the account list via a web browser. 

For example, if the proxy server address is 192.168.0.1 and the admin port is 88, you can 

go to http://192.168.0.1:88/ to access account management. When you open this URL it 

will require a username and password. If the username is identified with one of the 

accounts, you can access the details for this account and you can change the account's 

password. If the username is admin and the password is the admin password, you can 

change the information for all the accounts and also add or delete an account. 
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10 CCProxy Online Monitor  

We will explain the monitor function of CCProxy in this section. CCProxy provides a tool 

for administrator to monitor clients' Internet activities. 

You can click the "Monitor" button or double click the green grids on the main interface to 

open the monitor dialog box. 

Connections: to display the amount of online connections. 

Users: to display the number of online accounts. 

On the monitor dialog box, you will find three tabs that are Log, Account and IP. 

The log tab is used to display the clients' Internet access logs. 

The account tab is used to display the account's online information including connections, 

bandwidth and bandwidth usage. 

IP tab is used to display the online information of each IP address such as connections 

and account name. 

Send Message: to send messages to the clients. 

Note: This function requires both the clients and the server to have started the 

"Messenger" service. To do this, select "Control Panel -> Administrator Tools -> Services", 

and start "Messenger". This function is only supported in NT/XP/2003.  

Flow Status: to display the bandwidth usage of each user. 
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11 Contact 

support@youngzsoft.net 

Please read the FAQ and email to us if you have additional questions or problems.  

sales@youngzsoft.net 

Currently our products are only distributed on the Internet. If you are interested in 

exchanging links with us, or would like to help us with physical distribution, promotion in 

software compilations, or business cooperation, kindly let us know! We are open to 

various levels of cooperation.  

 

Homepage: http://www.youngzsoft.net/ccproxy/ 

How to Purchase: http://www.youngzsoft.net/ccproxy/purchase.htm 

FAQs: http://www.youngzsoft.net/ccproxy/faq.htm 

Feedback: http://www.youngzsoft.net/ccproxy/contact.htm 

 


